giovedì 21 ottobre 2010

Empathy non si connette ad MSN o Windows Live Messenger ecco la soluzione per Ubuntu 10.10

Siamo alle solite: Microsoft ha cambiato qualcosa nei propri server e adesso alcuni client (aMSN2, eMeSeNe2 ed Empathy) sono stati tagliati fuori.
Il problema si è verificato a partire dal 19 ottobre 2010 e adesso le modifiche si sono propagate anche in Italia.
Per risolvere il problema bisogna aprire una console e scrivere
sudo apt-get remove telepathy-butterfly
Adesso riavviate Empathy ed il gioco è fatto. Questa procedura cancellerà qualche funzionalità di MSN. Il problema è già stato risolto e a breve verrà rilasciato il nuovo pacchetto.
Se Empathy continua a non connettersi provate le seguenti soluzioni:
  • Verificate che non ci sia nessun processo che si chiami telepathy-butterfly;
  • Rimuovete e ricreate l'account MSN su Empathy;

~~ AGGIORNAMENTO ~~
21-10-2010
Dato che ho notato le difficoltà degli utenti sul forum ufficiale Ubuntu ho corretto leggermente l'articolo, e adesso cercherò di essere più chiaro:
  • telepathy-butterfly deve rimanere rimosso finchè non saranno rilasciati gli aggiornamenti adeguati nel repository ufficiale. Questa libreria utilizza la libreria di connessione msn papyon (utilizzata da emesene2 e amsn2, oltre che da empathy).
  • telepathy-haze, invece, è la libreria utlizzata da pidgin (attualmente su pidgin funziona il login msn).
22-10-2010
Ubuntu ha rilasciato l'aggiornamento ufficiale alla libreria Papyon. Per scaricarlo è sufficiente abilitare tutti i repository di aggiornamento dalle impostazioni del gestore aggiornamenti:

e dare, da shell
sudo apt-get update && sudo apt-get upgrade && sudo apt-get install telepathy-butterfly
Se siete possessori di Ubuntu Lucid 10.04, invece, dovete fare l'installazione di questo pacchetto a mano.

9 commenti:

Anonimo ha detto...

Grazie dell'informazione!
Ti ho linkato nel forum di ubuntu dato che in parecchi avevano lo stesso problema...
ho aggiunto i repo e sta aggiornando empathy...
poi provo a reinstallare butterfly e vedo se funziona correttamente
:)

Otacon ha detto...

Perfetto ragazzi. Sono contento vi sia stato utile.

Alessandro ha detto...

Scusate ma che versione di butterfly avete installato? Anche io ho rimosso e reinstallato ma continua a nn andare.

Otacon ha detto...

@Alessandro: non devi reinstallare butterfly. C'è già telepathy haze che fa le veci di butterfly.
Butterfly va solo rimosso!!!

Alessandro ha detto...

Ah ok, avevo interpretato male il commento di anonimo.
In pratica così si utilizza libpurple per connettersi a msn....uhmm...ma voi così riuscite ad effettuare videochiamate su msn?
(che nervi, erano 3 giorni che ero riuscito a farla funzionare e m'hanno cambiato il protocollo...grrrr!!)

Otacon ha detto...

Allora adesso funziona tutto:
se hai Ubuntu Maverick puoi reinstallare telepathy butterfly e aggiornare;
Se hai Ubuntu Lucid, invece, devi installare a mano questo pacchetto:
https://launchpad.net/ubuntu/+source/papyon/0.5.1-0ubuntu2/+build/2012735/+files/python-papyon_0.5.1-0ubuntu2_all.deb

Marco ha detto...

Da ieri basta aggiornare normalmente la distribuzione per risolvere il problema. Non è più necessario modificare nulla.
Saluti
Marco

Otacon ha detto...

@Marco: Sisi, infatti avevo scritto nell'aggiornamento del 22-10-2010 che basta fare l'update. Comunque grazie per il commento!!!

Anonimo ha detto...

MITICO

Posta un commento